R的安装配置与升级

R的安装配置与升级

这几天R 语言升级到了3.5 的版本,终于在小数点后面一位有了变化。关于新版本可以这这篇博客中查看 R 3.5.0 is released! (major release with many new features)

R 的安装配置和升级对大多数人来说都是比较痛苦的事情。这里简单总结一些的东西,希望对有需要的人有用。

  1. 安装最新版R永远可以通过后面的这个重定向链接直接下载:http://cran.r-project.org/bin/windows/base/release.htm

  2. windows 中默认安装目录带有R的版本号,比如C:/Program Files/R/R-3.5.0/,这就意味着你没安装一次R都会出现一个新的默认目录。在设置安装目录的时候可以把R的版本号去掉。

  3. windows 默认会把R安装在C盘,后面如果要安装很多其它包的话其实是没有写入权限的。这个时候最好使用 file.edit(‘~/.Renviron’) 添加一个 R_LIBS_USER 变量,用来指定R的附加包安装位置。一来是为了避免安装时没有权限的尴尬,二来是将附加包和R 分开,这样R 的升级不会影响到附加包。如果输入.libPaths() 会看到两个目录,其中一个是附加包路径,另一个就是默认安装的 R 主程序路径。

  4. windows 升级R 推荐使用installr,会提示你一步步升级然后帮你把旧版本里的主程序包拷贝到新的版本里。首先,install.packages(“installr”),然后installr::updateR()

  5. 正常来说接下来可以使用rvcheck包,对所有R中安装的各种包进行版本检查和升级。但是目前我测试发现bioconductor 的默认镜像和网址似乎国内已经登陆不上去了。需要设置一下bioconductor的镜像

  6. 如果使用R来做生信分析,一定需要用到bioconductor,在windows中它的升级也会遇到各种各样的问题。比如说:BiocInstaller version 3.x is too old for R version 3.x; 再比如说 InternetOpenUrl failed;再比如说 Error in read.dcf(file.path(pkgname, "DESCRIPTION"), c("Package", "Type")) : cannot open the connection

  • 针对第一点,解决方法如下
    重启R; 运行命令 remove.packages(“BiocInstaller”, lib=.libPaths()) 直到R 显示 there is no such package
    再运行命令 source(“https: //bioconductor.org/biocLite.R“);会对bioconductor 进行升级
    然后就是升级里面的R包
    运行 biocValid() 查看哪些包可以继续用哪些需要升级
    然后运行biocLite(“DESeq2”) 进行升级即可

  • 如果出现看起来是网络链接的错误或者包总是不能下载完整,那就需要设置镜像。
    首先可以使用biocinstallRepos(),查看一下目前再用的repos:
    目前可用镜像查看地址 https://www.bioconductor.org/about/mirrors/

chooseBioCmirror()
chooseCRANmirror()
source("https://bioconductor.org/biocLite.R")
biocLite()

本文作者:思考问题的熊

版权声明:本博客所有文章除特别声明外,均采用 知识共享署名-非商业性使用-禁止演绎 4.0 国际许可协议 (CC BY-NC-ND 4.0) 进行许可。

# R
Your browser is out-of-date!

Update your browser to view this website correctly. Update my browser now

×